Please or Register to create posts and topics.

Fusion 9.0.13 Prism menu tab does nothing at all

ok. thanks!

pip.exe will give me:

C:\Users\mr>C:\Python27\Scripts\pip.exe install PySide2
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.
ERROR: Could not find a version that satisfies the requirement PySide2 (from versions: none)
ERROR: No matching distribution found for PySide2

 

Sorry, I forgot that this version of PySide is not available on pip. But you can install the older PySide version instead, which works with Prism in Fusion too.

C:\Python27\Scripts\pip.exe install PySide

thank you. This worked: Successfully installed PySide-1.2.4 but I got a warning:

WARNING: The script pyside-uic.exe is installed in 'c:\python27\Scripts' which is not on PATH.
Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.

Is this necessary? the menu item still do nothing when I click on them.

thank you

 

 

Do you see an error in the scripting console in Fusion? I think if your python folder is not in PATH then Fusion might not be able to find your python installation and you won't be able to execute any python script in Fusion.

Can you type: print("test") in the console without error?

If not you can reinstall python 27 with the installer and in the setup there is an option to add the installation folder to PATH, but it's turned off by default.

Sorry for the hazzle: Yes, you're right. Python 2.7 wasn't present in Fusion. I reinstalled it with the PATH-option. Fusion (I think it wasn't there before) shows:

Traceback (most recent call last):

File "<nofile>", line 18, in <module>

ImportError: DLL load failed: %1 ist keine zul�ssige Win32-Anwendung.

in the console. But I receive 'test' when I call it, but still no luck with the menu. Thank you!

That sounds like some mix between 32bit and 64bit apps.

Did you install 32bit or 64bit python? Try to use the 64bit version (Windows x86-64 MSI installer)

64bit. I installed this one: python-2.7.18.amd64.msi

I updated to Fusion 9.0.2. Don't know if this message was there before... anyways: clicking the 'prism project browser' the console displays:

Traceback (most recent call last):

File "C:\Users\mr\AppData\Roaming\Blackmagic Design\Fusion\Scripts\Prism\3 Project Browser.py", line 49, in <module>

from PySide.QtCore import *

does this help? Sorry for all the trouble....

It sounds like there is no PySide installed with your Python 2.7. Can you execute from PySide.QtCore import * without error in the script editor in Fusion?

There are errors:

Py2> PySide.QtCore import *

File "<nofile>", line 1

PySide.QtCore import *

^

SyntaxError: invalid syntax

 

I installed PySide like you suggested above with:

C:\Python27\Scripts\pip.exe install PySide
when I reenter it, cmd will give me:
Requirement already satisfied: PySide in c:\python27\lib\site-packages (1.2.4)