Please or Register to create posts and topics.

Project not found, could not initialize The Project browser

Hello @richardf !

We are back in company and working on network drives on Windows, when I launch a scene through the project browser I have an error saying that Prism does not find the path of the project and then a second message saying : "could not initialize The Project browser".

It still opens the scene anyway (which means that the path exists),  I have not idea where it could come from, do you have any idea ?

Thanks a lot !

ValDo

I remember having this problem in the past, because the Prism tray was launched at system startup as a different user then the actual logged in Windows user. That caused the Prism tray to have a different active project than the Prism instances inside the DCC apps.

I just tried to open a Houdini scene from the tray icon with an active Prism project on the network, but it loaded the Houdini and Prism successfully.

Some more information would help to reproduce the problem.

Can you check in the Windows task manager in the details tab, from which username the PrismTray.exe process was started and if it's the same as the currently logged in windows user?

Are you using network paths for the Prism project or mapped network drives?

Are you in a non admin windows account?

Hello @richardf !

Thanks for the answer, I have tried to narrow down the bug and here is some pointers :

It seems that it only happens when I launch an Houdini scene from PrismTray.exe, I don't have this issue when I first open Houdini and use the project browser inside Houdini.

I went in windows task manager and PrismTray is launched as the current user, which has admin rights (it also happens on other machine which don't have admin rights as well)

We are using mapped network drives.

Also someone realised that launching Houdini through PrismTray is way longer than first launching Houdini and then using Prism Project browser to open a file. Maybe this could be related somehow ?

Thanks again for your time and work, you rock !

ValDo

Thanks for the details @valdomenhirfx

I found the issue and fixed it already for the next update. I changed the code quite a bit for this update, so I need a few more days for testing before I can upload it.

I hope that's no problem for you since you have a workaround.

Man, your are doing everything by yourself and giving it for free, so no that's not a problem at all haha !

Thanks a lot for taking a look at it, looking forward to it !

It took a while, but the fix for this is now included in the v1.3.0 update.