Please or Register to create posts and topics.

maya playblasts follow window aspect rather than render settings.

My render settings are set to a square aspect ratio, but my playblasts come out matching the aspect ratio of the viewport window (not square).

Strangely, even when I change the viewport to match, the results look wrong, as if they have an overscan value of 1.3 (the default).

 

Here's a simplified version of my shot to show the issue. I've included the entire heirarchy of this test shot.

https://www.dropbox.com/s/bz87vpkmty606he/pitch-test.zip?dl=0

 

 

If the resolution override in the Playblast state settings is disabled, Prism won't specify a resolution and Maya uses the viewport size by default and not the render resolution. It would be a new feature to add the option for using the render resolution.

The camera settings which Prism uses for playblasts are:

Fit Resolution Gate: Overscan
Overscan: 1.0

Probably the first setting causes the confusion, because you were using fill in your scene.

We have run into the same issue with our production. I understand that it isn't necessarily a bug, but it is quite important for previz. Having the option to get a playblast that fits your resolution gate, would definitely be preferable.

I just saw this old thread and wanted to mention that Prism now uses the "Fill" option for the fit resolution gate setting, which is the Maya default. But you can also turn of the Prism recommended settings in the playblast state settings and then Prism will use the settings, which are currently set in the scene.