Please or Register to create posts and topics.

MAYA: Additional playblast settings

12

The playblast export state is really great, and all the animators on the project is using it, and works well!

There's one problem though, it renders the gate mask. So even though you specify the resolution to for example 1280*720, it will not be the actual resolution of the playblast - see example attached. First of all I cant convert to mp4 because of the odd resolution, and secondly it's really unpractical to have the gate mask included for a number of reasons.

I did some searching and I found this from a forum post:
https://forums.autodesk.com/t5/maya-forum/playblast-to-match-resolution-settings/td-p/7986049

'Hi there,

I've just figured out that the specifications in theΒ  youtube link I previously asked about worked -so long as the "render offscreen" box was checked in the playblast settings.

So I can now achieve a rough animation playblast within the resolution gate!'

It seems like we need to render the playblast with the 'render offscreen' setting turned on, and I think we need the 'fit to resolution gate' also set.

Would it be possible to add thse settings to the playblast state?

Uploaded files:
  • You need to login to have access to uploads.

Are you sure the odd resolution is related to the gate mask? The documention says the resolution of the playblast gets clamped to the active window size, so maybe your viewport/maya window was too small when creating the playblast. The "render offscreen" option would help then, but in my test it was not clamped even if I had this turned off. Maybe they changed it in a recent version, but none of my test gave me wrong resolution.

That the gate mask is in the playblast is usually not intended, I agree. So you suggest to set the "fit to resolution gate" option to "fill" right before the playblast starts and then back to "overscan" after the playblast is done?

 

Yes, you are right, the resolution is from the window size, but ideally the gate mask should not be included in the playblast. I think the only way to get Maya to crop to the actual camera boundries is to use the 'render offline'. The overscan setting on the camera might needed to be set to 1, instead of the default 1.3 - maybe this is something Prism could automate? (if it is the case...)

One of the animators on the project managed to make 'perfect' playblasts, turns out he didn't use prism because of the same problem. I have asked him to share his settings, I'll update this post as soon as I know more.

Hi again, so this is the settings he used:

1. overscan on the camera is set to 1
2. gate mask is turned off in the viewport
3. Lastly I would check 'render offscreen'. In case you have 1080p monitor (like my cintiq and laptop) then sometimes the viewport not have a high enough resolution, and it get capped with a random size, like in the example in the first post. 'Render off screen' should solve this.

Do you think it would be possible to automate this with the playblast state? So basically do this steps on publish, and set it back to what it was after publish is done.

Uploaded files:
  • You need to login to have access to uploads.

Thanks for the details. Yes this is possible. Especially for the render state Prism sets many rendersettings just before the execution of the state and reverts them to the previous values after the publish. I just uploaded the changes, which automate these playblast settings. Now it should save the playblasts without the gate mask.

I created a 16k playblast on my 1080p laptop with render offscreen turned off. So I really don't understand what this setting does. But it is turned on now for all Maya playblasts in case it has any effect on other computers or other Maya versions.

Did you turned off the resolution override in the playblast state? If it is disabled then the current viewport size will be used and not the rendersettings as you might think. When using the current viewport size the chance is high that the resolution will be odd.

Thanks Richard! I just tested it and it seems to work perfectly πŸ™‚

Yeah, I might have switched that off, have to admit the playblast setting in Maya keeps driving me nuts. It seems like they are changing codecs and settings for every release, there's always something that is not working optimally, so it's really fantastic to have prism make a standarized way of making the playblasts that just work! Awesome stuff! πŸ™‚

Let's wait what they will change in Maya 2019. I hope most of the Prism features will work without any adjustments, but I guess Autodesk will have some genius ideas what could be changed.

btw: I really like the style of your characters. Is there already a release date for this movie?

Hehe, yeah I'm sure they will add some 'great' changes πŸ™‚

Thanks, we are aiming for March 2019. We are just about to go into animation.

Hi again,

Turns out the prism playbalst somehow does not keep the viewport settings. Would it be possible to add the commands for 'show -> none', and then add 'show -> polygons'?

I made ashort video to explain the problem:

https://app.hyfy.io/v/abEJ8WhdMsn/

Mh, it works fine for me. Could it be that you had the "Camera" option in the playblast state set to "Don't override" and the right viewport selected and selected the cam in the dropdown after the playblast? In my tests he always used the settings from the currently active viewport and set the camera in the current viewport to the cam which is selected in the dropdown in the state settings. Tested in Maya 2017 and 2018. I would rather not force any display settings by default in Prism if it's not for sure what's the exact problem.

 

12