Please or Register to create posts and topics.

Linux installation failing

Hello,

I'm trying to install Prism v1.2.0 on Ubuntu 19.10.
I'm following the installing documentation https://prism-pipeline.readthedocs.io/en/latest/index/feature_reference/#installation-dialog

I downloaded the tar.gz and extracted it in home/me/bin/ in which I should install Prism. I previously added home/me/bin/ in the PATH variable, if I run %echo $PATH there is that path at the end of the string.
Then, if I run:

% cd /home/me/bin/Prism_v1.2.0_Linux/
% sudo ./Prism_setup_Linux.sh

I get:

Traceback (most recent call last):
File "Scripts/PrismInstaller.py", line 65, in <module>
from PySide.QtCore import *
ImportError: libpython2.7.so.1.0: cannot open shared object file: No such file or directory
Traceback (most recent call last):
File "Scripts/PrismCore.py", line 68, in <module>
from PySide.QtCore import *
ImportError: libpython2.7.so.1.0: cannot open shared object file: No such file or directory

I found another post in this forum in which there were adviced to rename a "lib_inactive" folder into "lib" inside .../Prism_v1.2.0_Linux/Prism/PythonLibs/, but in my case it was already named simply "bin". I have both python 2.7.17 and python 3.7.5 installed on this system. Also I'm not very familiar with Linux systems, so maybe I can be doing something wrong.

Thank you in advance

The Prism installer needs Python 2.7 at the moment, but I think your default python version on Ubuntu 19 is python 3. You can check by typing "python" in a terminal.

You could change the default python to python 2.7, but it would be easier to change these two files in your Prism directory:

Linux_Setup_Integrations.sh
Linux_Setup_Startmenu.sh

They contain commands, which starts with "python", which uses your system default python. Instead you can replace "python" by the command or the absolute filepath of your python 2.7 installation. I don't have Ubuntu 19 here to check the exact location of python 2.7, but that should be easy to find.

actually typing just "python" in my terminal it runs Python 2.7.17, so python2 should be the default python in my system.

Anyway, I replaced the "python" commands in that two files with "/usr/bin/python2" (which is my python install path), for example in Linux_Setup_Integrations.sh:

/usr/bin/python2 "Scripts/Linux_Pre-Install.py"
/usr/bin/python2 "Scripts/PrismInstaller.py"

but the error remains.

After googling a bit it seems like libpython2.7.so.1.0 should exist somewhere on your system already. I'm not sure why it can't be found, but there are quite a few solutions on google. I'd have to install ubuntu 19 to figure out if it's because of the OS or something else. I'll install it when I find the time, but maybe you can solve it in the meantime with one of the solutions if you search for that error message.

thank you very much, I'll try to figure it out