Please or Register to create posts and topics.

Houdini crash on startup v1.3.0.9

Hello Richard,

First of all, thanks a lot for the update, it's really great and we are loving it !

On one of our workstation, Houdini (18.0.499) is crashing on startup only when Prism (v1.3.0.9) is integrated. If I remove the Prism integration through the prism settings, Houdini does not crash anymore.

It's working fine on other machines, so I am unable to pin point the issue ... 😐

Do you have any idea where it could come from ? I re-installed Houdini and Prism already and it didn't solved the issue

Thanks a lot,

ValDo

Hey ValDo,

Nice to hear that you love the update 🙂

All your workstations are using the same Houdini version? Are there any other plugins installed? Prism standalone is working?

One common problem that can cause crashes is that a software gets imported into another software and both programs were compiled with a different compiler version. The Prism code is not compiled because it's just python code, but some 3rd party modules are compiled like OpenImageIO.

So what you can try is to delete or temporarily rename the folders of the 3rd party modules, which are included in Prism and get loaded through Prism when you start Houdini. Everything in this folder "C:\Prism\PythonLibs" except "C:\Prism\PythonLibs\CrossPlatform\ruamel" is not essential when you start Houdini with Prism. Maybe it fixes your crash if you remove these optional modules.

Hello Richard,

Yes we are using the same version of Houdini (and Redshift) on each workstation.

I'll try what you told me and get back to you in a few.

Thanks for being super reactive (as usual !)

EDIT : And Prism Standalone is working fine

Hey again !

So good news, it's now working fine and I might have an idea of what happened (If someone has the same issue) :

The standalone had no active project and crashed, after I did set a project in the standalone version, Houdini didn't crashed at launch anymore.

Thanks again for your time !

Glad you found the reason.

When I delete my my Prism preferences and start Houdini the "Set Project" dialog opens fine. But I'm using a slightly newer Houdini version, which could play a part in that.

I had/have this same problem too - it's pretty frustrating

Have you tried the fix that I described ?