You need to log in to create posts and topics.

Arnold Shaders blocked through Prism + Misc problems

Hello,

So there are a couple things going on that I'm not entirely aware how to fix if there is one.

First things first though, these are the versions I'm using:

  • Houdini - v17.5.327
  • Prism - v 1.2.0
  • Arnold - v4.2.0

Alright, on to the issues. The first being that I cannot load Arnold shaders when I open a scene through Prism. When I double click on a particular scene through the Project Browser (any houdini scene), wait for it to open (this is another issue), go into the SHOP context to create an Arnold material, dive in, and press Tab, there is almost nothing there. However when I open Houdini by itself, instead of through Prism, it works just like it should. I even tried creating a new Empty File Preset, from a standard Houdini launch, to see if it would recognize that I should the tools available to me but it didn't work. I decided to take a screenshot of the two side-by-side to illustrate what I am talking about. Hopefully it uploads just fine. Prism did not report an error during this.

My second issue is that I cannot get the Prism Shelf or any Prism tools to open or become available. It's also missing. I noticed that you had covered this topic earlier by 'imoh3n', however I'm not getting any errors like he did in the Houdini Console. I added this version in the 'DCC Apps' tab, I tried an Executable Override, I tried uninstalling and re-installing Prism, and I tried a new file (I'm sure I tried a couple more as well I just can't think of it).

Third issue (rather inconsequential really), is that anytime I open a scene through Prism it takes a really long time to open. I mean it takes about 1.5min compared to like 15 seconds for a normal houdini launch and I have both Prism and Houdini loaded onto an SSD.

Not sure if there is something going on that I'm not aware of but I feel like I've done my due diligence in hunting to solve this problem and trying to find workarounds, so I'm coming here for some help (or just reporting some bugs). I've not had any issues in the past with this, so I thought it strange that issues pop up now.

Sorry for the essay...

Thanks

Uploaded files:
  • missingArnoldShaders.png

I guess it's a similar problem like the one imoh3n had. The reason why you don't get the error message is probably because you are using a different Prism version.

If Houdini is started as a different Windows user, Houdini will use a different preferences folder. And if your Arnold is setup only in one specific houdini.env file, this would explain, why some shelfs and nodes are missing.

Can you execute this in the python console in Houdini and compare it in the session which was started manually and the one started through Prism?

import os
os.environ["HOUDINI_USER_PREF_DIR"]

 

Sorry it took so long to get back to you, haven't had much time to do so. I ran the script in both the standard houdini and the file started through Prism and both came back saying the same thing. Currently I am the only user using Prism for my Projects. I attached a screenshot displaying the results.

 

Uploaded files:
  • Screenshot_2.png

Wait, actually I can access my Arnold shaders now. I'm not entirely sure what happened since the last time I opened it, but it works. However I am still missing the Prism Shelf tools.

If it's just the Prism shelf, which is missing, then maybe the Prism Houdini integration is not setup. If you are using Prism v1.2.0.0 you should have a Prism shelf file in your Houdini prefences folder: C:\Users\username\Documents\houdini17.5\toolbar\Prism.shelf (In the latest Prism dev version that changed).

If you don't have this file open the Prism Settings dialog for example from the Prism Tray and in the DCC Apps tab you can add the Prism Houdini integration to your Houdini preferences folder.

If the .shelf file already exists I guess the shelf is already loaded in Houdini but not visible by default. Click on the white plus on the top right of your shelf set in Houdini. Under "Shelves" in this menu you will see a list with all available shelves. Check if "Prism" is in that list, maybe it's not checked.

Ok so good news (very late but good), the shelf was purely user error. I was choosing the wrong Documents folder Houdini draws from to integrate Prism into. The average person probably has their documents and software point to the C:/ directory. However since I only wanted my OS on that drive, I changed it to H:/. This created 2 Documents folders in the beginning, and was the root of the confusion, but now it has been resolved. Thank you very much for your patience and responses, I greatly appreciate it.