Please or Register to create posts and topics.

Prism v1.3.0.83 windows & Blender 3.10


I started to use Prism a few weeks ago in solo mode and its a great tool!

I use it with Blender 3.0 and works fine but when I tried it with Blender 3.10 I cant see the "Prism Menu".

Searching a bit, I found out that Blender 3.10 uses Python 3.10 and Prism only supports Python 3.7  & 3.9.

Is there a plan to add Blender 3.1 to the supported app?

Thank you!



I'll take a look next weekend and try to push a fix, as 3.3 looms closer and closer we'll be starting to move away from 2.93 and prism is just critical for us to have at this point

Hi @gstorni I made a pull request on prism repository with the fix, the fix itself is trivial, but in the meantime while Richard gets around to reviewing it what you can do is:    (Alternatively go to the last step described here if you want to skip a bunch of steps.)

-from Prism Preferences, uninstall the plugin from 3.1 (C:\Program Files\Blender Foundation\Blender 3.1\3.1\scripts\startup should not have

-Go to the folder where Prism is installed, this will be by default C:\Prism

-here you will navigate to \Plugins\Apps\Blender\Integration

-Open with a Text editor (notepad, notepad++, Sublime, VSCode, etc.  DO NOT use word or other formatted text editors).

-look for line 44, it should read as follows:

if sys.version_info[1] not in [7, 9]:
    raise RuntimeError("Prism supports only Blender versions, which are using Python 3.7 or Python 3.9")

-Change it to:

if sys.version_info[1] not in [7, 9, 10]:
    raise RuntimeError("Prism supports only Blender versions, which are using Python 3.7, Python 3.9 or Python 3.10")
-And that's it, just re-install prism to 3.1 and it should work
-Alternatively instead of deleting on Step 1, you just perform the edits there and that way you wont have to reinstall anything, the difference is that if you download other versions that require the fix you would have to do it for each one of them after install.
Hope this helps.

Hello Animatect,

Thank you for you reply and explanation!

I tried it on 3.2.0 and so far it seems to be working fine.

Ill do a more intense tests these coming days.

Thanks again!



unfortunately i can't make it work on official blender 3.(0-2) 🙁

is there anything else i have to take care of?

i'm on latest prism

Uploaded files:
  • You need to login to have access to uploads.

Hi @deltahoch3

I been using it for a couple of weeks now and seems to be no problem.

My workflow is the following.

I'm doing the modeling/animation/etc on my machine 3.2.0 and the root of the project in Google Drive Shared Disk.

For rendering I'm using another computer in another location that has 3.0.2 and Prism on the same google drive and there's is no issues.

here are some pics of my installation. Hope it helps.



Uploaded files:
  • You need to login to have access to uploads.

I haven't used it much on 3.1 and 3.2 but there are some minor problems with integer/float calculations, f.e. setting fps and resolution based on a default project settings doesn't work. I'll test it with shotgrid and deadline integration too in my free time, I suspect more of these, hopefully small problems will be found there.