Please or Register to create posts and topics.

New RenderManager plugin doesn't show up in list

When I create a new RenderManager plugin it doesn't show up in the plugin list. I have restarted Prism, tried copy it over to my plugin folder per project but nothing. I have tried different names like Kitsu and Test but no difference.
If I create an App or Custom plugin it shows up directly.

Am I doing something wrong, missing something? The shotgun plugin shows up so it's nothing wrong with the plugin folder itself.

Since you mentioning Kitsu and Shotgun I assume you mean ProjectManager type plugins instead of RenderManagers.

In the file there is an "isActive" function. The plugin shows up in the plugin list only if this function returns True. ProjectManager plugins by default return True only when run in Python 2, but Prism is using Python 3 in the latest version.

This is a remaining behavior from a while ago, when the Shotgun Python API was only compatible with Python 2. I'll change the default for this function to return always True in the next update.

Yes I ment ProjectManager, sorry about that!

Great then I know what's going on 🙂