Please or Register to create posts and topics.

Problem in rendering scene by using Pandora

We are using Blender v2.79 to create an animation of a wrc car. We have created dust using Blender’s smoke and cached the simulation in our local network. It’s perfectly fine when we render the scene locally in any computer.


But as soon as we put it to network render using Pandora, the dust doesn’t render properly.It renders just the part. Image attached.

Uploaded files:
  • You need to login to have access to uploads.

I moved this topic to the Pandora forum.

Is it possible that Pandora uses a different Blender version than you would expect? Is the cache cut off or could this be the cache from a wrong frame at the beginning of the simulation?

Are there any errors in the slave log? You can find the log when you rightclick on the slave tray->Open slave root. There is a file called slaveLog_....txt. You can upload it here so I can have a look (or send it to me via mail).

Another thing you could test: From the tray click on "Open slave repository" there in the subfolders you can find the actual scenefile which will be rendered by the slave. You can open this file in Blender and render it locally to see if the problem is happened during the submission or if it renders fine and the problem only occours during command line rendering.

Thank you for your quick and helpful response.

  1. The Blender version is exactly the same on all machines v 2.79b
  2. I rendered the file from the slave repository but the dust was missing again in output render.

To describe our setup:

1: We are using a network drive which is mounted on Pandora slave and coordinator machine as  Z:\ drive.

2: We set  Z:\ drive as a root drive in Pandora slave and coordinator.

3: Our render file, cached file, texture and other linked file are in Z drive.

Some error reference image, error details file and log are attached as a .zip file.


I just added to option to upload .zip files here in the forum. Now you can attach it.

File attached.

File Name -

Uploaded files:
  • You need to login to have access to uploads.

In some cases Prism uses the "save as" command in Blender when submitting a job. The default options of this command converts all paths to relative paths. This caused the wrong cache path in your submitted scene. During the submission Prism used the "save as" command and Blender made the cache path relative. Then the scenefile was copied to the slave and the relative paths pointed to a wrong location. I guess the smoke you see on the wrong rendering is the inital frame of the sim, which will be used when no cache is found or something like that.

Prism uses the "save as" command only when you have the "Submit dependent files" checkbox checked in the submitter dialog. Since you are using a server where you save everything you can turn off this option. But make sure all your textures, alembics... are on Z:/ too.

That should work for you and I'll fix the wrong behaviour when using the "Submit dependent files" option in the next update.

I unchecked "Submit dependent files" option but there was no changes in render output.

Please check the log file.

Uploaded files:
  • You need to login to have access to uploads.

In the error log there are many lines with:

[1] 17.10.18 12:23:23 : Info: Saved packed file to: C:\Users\hp\Documents....

That means that all assets/textures were packed into the current Blender scene. Prism does this only if the "Submit dependent files" option is enabled. Did you use the "File->External data-> pack all into .blend" command manually? Or could it be possible that you mixed up the new job with an old one?
Of course you need to submit a new job to have this option to take affect. You cannot change the "Submit dependent files" setting for already submitted jobs.

Thanks for your prompt support and valuable time. Your last post worked for us.