You need to log in to create posts and topics.

"error : rendering didn't produce any output" - On certain machines

Hi Pandora,

I'm the IT guy at a VFX school, and fairly new in the field coming from an VFX background and not so much IT itself.

We've been struggling to find a great render tool to help our students, but found Pandora, and it looks perfect for us. I installed and set it up, and everything seemed to run fine, did however get the issue with the shelf in maya not showing up until a manual delete and restart.

However, I implementet a new Deployment system for our machines using Microsoft MDT, but for some reason everything renders fine on the machines that i haven't run our deployment on, but all the newly deployed machines fails to render. It basically just quickly gives me the "error : rendering didn't produce any output"

So far the log hasn't been much help to me, I've looked into everything i feel like, permissions etc, everything should run from an admin account, yet still fails. Maybe i'm overlooking something, that you can point out for me. So sorry for the inconvenience, really liking the software!

This is the log i get from the failing machines (Basically looping forever):

[1] 11.06.19 14:13:13 : complement config: updateTime 10

[1] 11.06.19 14:13:13 : complement config: maxCPU 30

[1] 11.06.19 14:13:13 : complement config: preRenderWaitTime 0

[1] 11.06.19 14:13:13 : complement config: debugMode False

[1] 11.06.19 14:13:13 : complement config: slaveGroup []

[1] 11.06.19 14:13:13 : complement config: showSlaveWindow False

[1] 11.06.19 14:13:13 : complement config: enabled True

[1] 11.06.19 14:13:13 : complement config: cursorCheck False

[1] 11.06.19 14:13:13 : complement config: command

[1] 11.06.19 14:13:13 : complement config: restPeriod [False, 9, 18]

[1] 11.06.19 14:13:13 : complement config: connectionTimeout 15

[1] 11.06.19 14:13:13 : complement config: showInterruptWindow False

[1] 11.06.19 14:13:14 : Slave started - v1.0.3.0

[1] 11.06.19 14:16:33 : starting task0000 from job Ball

[1] 11.06.19 14:16:33 : call maya

[3] 11.06.19 14:16:35 : rendering didn't produce any output - task0000 - Ball

[1] 11.06.19 14:16:35 : task failed

[1] 11.06.19 14:16:44 : starting task0002 from job Ball

[1] 11.06.19 14:16:44 : call maya

[3] 11.06.19 14:16:45 : rendering didn't produce any output - task0002 - Ball

[1] 11.06.19 14:16:45 : task failed

[1] 11.06.19 14:16:55 : starting task0003 from job Ball

[1] 11.06.19 14:16:55 : call maya

[3] 11.06.19 14:16:57 : rendering didn't produce any output - task0003 - Ball

[1] 11.06.19 14:16:57 : task failed

[1] 11.06.19 14:17:06 : starting task0011 from job Ball

[1] 11.06.19 14:17:06 : call maya

[3] 11.06.19 14:17:08 : rendering didn't produce any output - task0011 - Ball

Hey,

thanks for using Pandora. Handling all the IT for a new renderfarm is probably not an easy task especially when you come from a different background. But I'll try to help you as good as I can with the Pandora part.

I'm not sure what's causing the problem with the Maya shelf. Pandora creates a simple file here: C:\Users\richa\Documents\maya\2019\prefs\shelves\shelf_Prism.mel and this should load out of the box. Let me know if that's something you want to debug further.

I don't really know Mircosoft MDT so I don't know how it works exactly. The error "error : rendering didn't produce any output" comes from Pandora and is not something that was returned from the Maya process. And because this error occurred two seconds after Pandora started the Maya process I guess that Maya didn't even start.

By default Pandora tries to read the Maya executable path from the windows registry. If it cannot find a Maya executable it will write that as an error in the log. So it looks like Pandora found a Maya executable, but maybe it's not the one which you expected if Mircosoft MDT installs it in a different way. You can enable the debug mode in the SlaveSettings in the RenderHandler and try to start the job again. It will print the exact command in the log, which Pandora uses to launch the Maya process. This command contains also the path to the Maya executable. Have a look if that's the correct one.

How good are your python skills? (In case we need to do some further debugging)

Hi,

Thank you so much for the quick response. 🙂

Regarding the maya shelf, its no problem, the answer was right in the documentation. And that part is working now without issues.

I'm fairly certain you are correct regarding maya not even starting, I actually think that's the entire issue. And i'm almost certain that is has something to do with executing maya somehow, because it works on the machines that was previously just cloned harddrives.

I will quickly just try what you mentioned and come back to you. Our maya is in the standard maya location, MDT basically just deploys a windows with all the software installed as part of the windows image.

So i assume C:\Program Files\Autodesk\Maya2018\bin\Render.exe is where i want it to look at?

My python is unfortunately limited. I understand the basics, but can't write a big code without looking stuff up. I do however usually understand whats going on when reading python.

This is what i get:
[0] 11.06.19 21:10:52 : start checking assignments

[0] 11.06.19 21:10:52 : handle cmd: ['renderTask', u'rfobbnmvhb', u'Ball', u'task0002']

[0] 11.06.19 21:10:53 : communicate out: ['taskUpdate', u'rfobbnmvhb', u'task0002', 'rendering', '', 1560280253.169, '']

[1] 11.06.19 21:10:53 : starting task0002 from job Ball

[0] 11.06.19 21:10:53 : starting maya job. Ball

[1] 11.06.19 21:10:53 : call maya

[0] 11.06.19 21:10:53 : thread started

[0] 11.06.19 21:10:53 : [u'C:\\Program Files\\Autodesk\\Maya2018\\bin\\Render.exe', '-r', 'file', '-rd', u'\\\\tm-fs01\\Student\\student\\3DDA_17\\sem04\\theAcademy\\Rendering\\Pandora\\q05_s0100\\output', '-im', u'q050_s0100_pandoraTest', '-s', '11', '-e', '15', '-cam', u'persp', u'C:\\Users\\Damm\\Documents\\PandoraRepository\\Slave\\Jobs\\rfobbnmvhb\\JobFiles\\testScene_v001_CD.ma']

[3] 11.06.19 21:10:54 : rendering didn't produce any output - task0002 - Ball

I get this from the machines that work:

[0] 11.06.19 21:10:54 : handle cmd: ['renderTask', u'rfobbnmvhb', u'Ball', u'task0003']

[0] 11.06.19 21:10:55 : communicate out: ['taskUpdate', u'rfobbnmvhb', u'task0003', 'rendering', '', 1560280255.292, '']

[1] 11.06.19 21:10:55 : starting task0003 from job Ball

[0] 11.06.19 21:10:55 : starting maya job. Ball

[0] 11.06.19 21:10:55 : thread started

[1] 11.06.19 21:10:55 : call maya

[0] 11.06.19 21:10:55 : [u'C:\\Program Files\\Autodesk\\Maya2018\\bin\\Render.exe', '-r', 'file', '-rd', u'\\\\tm-fs01\\Student\\student\\3DDA_17\\sem04\\theAcademy\\Rendering\\Pandora\\q05_s0100\\output', '-im', u'q050_s0100_pandoraTest', '-s', '16', '-e', '20', '-cam', u'persp', u'C:\\Users\\birk\\Documents\\PandoraRepository\\Slave\\Jobs\\rfobbnmvhb\\JobFiles\\testScene_v001_CD.ma']

[1] 11.06.19 21:10:59 : [Redshift] Redshift for Maya 2018

[1] 11.06.19 21:10:59 : [Redshift] Version 2.6.38, Mar 26 2019
Followed by a lot of redshift stuff.

The only difference i see is:

"Call maya" and "Thread started" being reversed.

That the two commands are in a different order doesn't mean anything. They were created by two different threads, which run parallel so it's likely that the order can change.

The next thing you should check if the Maya command line rendering works (without Pandora). To do that open a normal windows command prompt and execute this:

"C:\Program Files\Autodesk\Maya2018\bin\Render.exe" "C:\Users\birk\Documents\PandoraRepository\Slave\Jobs\rfobbnmvhb\JobFiles\testScene_v001_CD.ma"

Note the single backslashes and the quotes. This should start the Maya process and render the scene. You should see some information from the Maya process in the command prompt while it loads and renders the scene.

Hi again Richard,

Tried the above, and it doesn't run anything. And as suspected it does run on the working machines, so i expect the problem to lie within the cmd not being able to run the render.

It does however seem to run the render.exe, it just closes down immediately. Where as on the old pcs, it will start mayabatch.exe and start rendering.

 

So either the render.exe or the mayabatch.exe is broken on your new computers.

What is the output when you execute this:

"C:\Program Files\Autodesk\Maya2018\bin\mayabatch.exe"

Do you see any output from that in the command prompt?

This thread from the Autodesk forum gives some options, which you could try:

https://forums.autodesk.com/t5/maya-forum/render-exe-not-working-maya-2018/td-p/8767742

You could run this:

"C:\Program Files\Autodesk\Maya2018\bin\Render.exe" -verb

to get a more detailed output from that process.

You could reset the preferences and uninstall all the Maya plugins (that was the solution for that guy)

Or you could check out the ProcessMonitor tool which he mentioned.

Maybe it's an option to install a newer service pack for Maya 2018?

Hi Richard,

Found out finally that NGSkinTools was causing the issues. I'm so close to have Pandora up and running.

I'm struggling getting it to run on our server. The instructions are simple and clear but this:

Now you can execute this script with Python 2.7. A log file called “PandoraCoordinator_Log.txt” will be created in the same folder and it should contain a line, which includes “starting Coordinator”.

Isn't working for me.

My structure is \\servername\Pandora\Root\PandoraFarm\Scripts\PandoraCoordinator\PandoraCoordinator.py but when i run it, nothing happens.

It does however seem from when i installed the coordinator locally that the structure should be \servername\Pandora\Root\Scripts\PandoraCoordinator\PandoraCoordinator.py without the PandoraFarm?

Making the documentation misleading i think, but i could be wrong 🙂 Can't get it to run from their either though.

 

 

I decided just to use the installer on the server, and I am now seeing green renders, and the images are getting output! 🙂

Your software just made a whole school incredibly happy.

Thank you for your great work on this! 🙂

I just have 2 questions left for now:

It seems like my coordinator keeps closing itself everytime i add a new slave? Is it supposed to do that? It's not a big deal, the coordinator just need to be restartet.

Another question: When a slave have finished a task, lets say frame 6-10, is there a way to tell it to rerender frame 8 and 10 without having to rerender 6,7,9.

Im unsure if i delete the frame 8, and restarts the task, if it only renders missing frames or them all.