You need to log in to create posts and topics.

maya pandora cannot render

on simple test see error...

[1] 05.04.19 10:39:37 : starting task0009 from job shot_SQ010-sh010_ren_Rendering_v0008_render01_csi_---Rendering
[1] 05.04.19 10:39:37 : call maya
[3] 05.04.19 10:39:39 : rendering didn't produce any output - task0009 - shot_SQ010-sh010_ren_Rendering_v0008_render01_csi_---Rendering
[1] 05.04.19 10:39:39 : task failed

using arnold render

maya and arnold test not working

see log

[1] 12.04.19 02:05:04 : SlaveLog cleared
[1] 12.04.19 02:05:05 : starting task0000 from job 111111
[1] 12.04.19 02:05:05 : call maya
[3] 12.04.19 02:05:05 : ERROR - runInThread - argument of type 'int' is not iterable - <type 'exceptions.TypeError'> - 1312
[1] 12.04.19 02:05:05 : stopRender - msgPressed = False
[1] 12.04.19 02:06:14 : stopRender - msgPressed = False
[1] 12.04.19 02:06:14 : slave restarting
[1] 12.04.19 02:06:16 : Slave started - v1.0.3.0
[1] 12.04.19 02:06:17 : starting task0000 from job 111111
[1] 12.04.19 02:06:17 : call maya
[3] 12.04.19 02:06:17 : ERROR - runInThread - argument of type 'int' is not iterable - <type 'exceptions.TypeError'> - 1312
[1] 12.04.19 02:06:17 : stopRender - msgPressed = False

Can you turn on the debug mode checkbox in the slave settings (lower right corner in the Render Handler when the slave is selected) and try to render again? Then there will be more detailed information in the log.

[1] 13.04.19 10:49:26 : SlaveLog cleared
[0] 13.04.19 10:49:27 : communicate out: ['taskUpdate', u'ngndpusask', u'task0000', 'rendering', '', 1555170567.105, '']
[1] 13.04.19 10:49:27 : starting task0000 from job 111111
[0] 13.04.19 10:49:27 : starting maya job. 111111
[1] 13.04.19 10:49:27 : call maya
[0] 13.04.19 10:49:27 : thread started
[0] 13.04.19 10:49:27 : [u'C:\\Program Files\\Autodesk\\Maya2019\\bin\\Render.exe', '-r', 'file', '-rd', u'C:\\Users\\c17vfx\\Desktop\\test\\222', '-im', u'demo', '-s', '1', '-e', '1', '-x', 640, '-y', 360, '-cam', u'persp', u'C:\\Users\\c17vfx\\Documents\\PandoraRepository\\Slave\\Jobs\\ngndpusask\\JobFiles\\1111.mb']
[3] 13.04.19 10:49:27 : ERROR - runInThread - argument of type 'int' is not iterable - <type 'exceptions.TypeError'> - 1312
[1] 13.04.19 10:49:27 : stopRender - msgPressed = False
[0] 13.04.19 10:49:27 : communicate out: ['taskUpdate', u'ngndpusask', u'task0000', 'ready', '', '', '']
[0] 13.04.19 10:49:27 : start checking assignments
[0] 13.04.19 10:49:27 : giving back assignment of task0000 from job 111111
[0] 13.04.19 10:49:27 : communicate out: ['taskUpdate', u'ngndpusask', u'task0000', 'ready', '', '', '']
[0] 13.04.19 10:49:27 : no task assigned
[0] 13.04.19 10:49:47 : start checking assignments
[0] 13.04.19 10:49:47 : handle cmd: ['renderTask', u'ngndpusask', u'111111', u'task0000']
[0] 13.04.19 10:49:48 : communicate out: ['taskUpdate', u'ngndpusask', u'task0000', 'rendering', '', 1555170588.592, '']
[1] 13.04.19 10:49:48 : starting task0000 from job 111111
[0] 13.04.19 10:49:48 : starting maya job. 111111
[1] 13.04.19 10:49:48 : call maya
[0] 13.04.19 10:49:48 : thread started
[0] 13.04.19 10:49:48 : [u'C:\\Program Files\\Autodesk\\Maya2019\\bin\\Render.exe', '-r', 'file', '-rd', u'C:\\Users\\c17vfx\\Desktop\\test\\222', '-im', u'demo', '-s', '1', '-e', '1', '-x', 640, '-y', 360, '-cam', u'persp', u'C:\\Users\\c17vfx\\Documents\\PandoraRepository\\Slave\\Jobs\\ngndpusask\\JobFiles\\1111.mb']
[3] 13.04.19 10:49:48 : ERROR - runInThread - argument of type 'int' is not iterable - <type 'exceptions.TypeError'> - 1312
[1] 13.04.19 10:49:48 : stopRender - msgPressed = False
[0] 13.04.19 10:49:48 : communicate out: ['taskUpdate', u'ngndpusask', u'task0000', 'ready', '', '', '']
[0] 13.04.19 10:49:48 : start checking assignments
[0] 13.04.19 10:49:48 : giving back assignment of task0000 from job 111111
[0] 13.04.19 10:49:48 : communicate out: ['taskUpdate', u'ngndpusask', u'task0000', 'ready', '', '', '']
[0] 13.04.19 10:49:48 : no task assigned

Sorry for my late reply.

There was a bug in Pandora when you tried to override the resolution for Maya jobs in the job settings.

I just uploaded the fix as part of version 1.0.3.2 to github. You can update your version from the Pandora Settings dialog to the new version.

workss! thanks man 😉

well now it does not give me the pandora option with the prism

Uploaded files:
  • prism.PNG

Did you see them previously? Can you open the Pandora submitter tool from the Pandora shelf? When this works you should also see it in Prism. Check if Pandora is listed in the "Plugins" tab of the Prism Settings and press reload all plugins if not. Which Prism version do you use?