Please or Register to create posts and topics.

Installed on new machine and nothing happens

12

I love Pandora, have it deployed on a few machines but when I installed it on a brand new render box (12 x 1070ti), after the installer gets to the Completing Pandora Setup, with any or all of the options (setup integrations, etc) selected, nothing happens. No tray icons, no errors, it just quits.

Attempting to run the individual bat files for setting up the integrations or startmenu, nothing happens.

Manually launching Pandora Tray, Slave, Settings, etc. Nothing happens.

By nothing, I mean no errors, nothing showing up in task manager, nothing in the tray.

System: Windows 10 Pro (up to date to today), CUDA drivers (installed yesterday), and Blender 2.83.4. -- This is the same config on the other machines and all work without any issue, only difference with this one is it has a bunch of GPUs in it.

Also, is there a way I can get any sort of debugging info to you?

This sounds similar like this topic about Prism:

https://prism-pipeline.com/forum/topic/after-update-to-1-3-0-6-prism-doesnt-start/

Can you try to apply the same fix for Pandora, by changing the .bat files to absolute paths?

Set to absolute paths and same result.

Switched to python.exe instead of pythonw.exe and now I see

Traceback (most recent call last):
File "C:\Pandora\Scripts\PandoraCore.py", line 71, in <module>
from PySide2.QtCore import *
ModuleNotFoundError: No module named 'PySide2'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "C:\Pandora\Scripts\PandoraCore.py", line 81, in <module>
from PySide.QtCore import *
ModuleNotFoundError: No module named 'PySide.QtCore'

Hi There,

I've the same problem with the update of Pandora, set the absolute path and nothing happen... :/

 

Looked a little deeper into this and found that the machines running properly are on 1.1.0.3 whereas the new machine that 'does nothing' is 1.1.0.4.

I'll be switching to 1.1.0.3 on the new machine as a workaround for now.

The difference between v1.1.0.4 and v1.1.0.3 is just a small bugfix, which has nothing to do with the startup process. I'd be surprised if that's the reason for this problem, but let me know if that made a difference on your machine @thedailyspank

The error you had sounds like your .bat file is not pointing to the Python37 folder or this file doesn't exist in your Pandora folder:

\PythonLibs\Python37\PySide\PySide2\__init__.py

Can you check if one of both is the case?

 

Hi Richard,

This is very weird. On some machines it starts up without a hitch. But on other machines the pandora just won't start. No errors or anything. It just doesn't start. There were no issues or errors during the installation of Pandora.

I checked for the file above and it sits in the right folder.

Let me know if i can be of any help because we have machines that do work and ones that don't.

Thanks,

Dennis

Is it possible to have some sort of debugging mode? Running from a command prompt doesn't give any feedback.

Hello, I have the same issue on our server, I'm unable to install and launch Pandora.

It's working fine on our workstation though

Does anybody has some new results ?

I've tried the new version, v1.1.0.5, still the same issue. Probably wasn't a fix for this anyway. But could try and hope for the best.

I'm no coder or anything, but if you need any assistance i'm glad to help. let me know.

12