Please or Register to create posts and topics.

Blender 2.91 not working

Hi guys!

I'm a Thecnical Artist located at Lightfarm Studios, in Brasil. I've installed the last versions of Prism on my personal computer to do some pipeline tests for the studio, using Houdini 18.5, Blender 2.91, everything running in Linux Fedora

Prism is working fine, so Houdini, but I had some problems with Blender. The Prism menu is there, but there's no content at all to proceed

Any tips?

Uploaded files:
  • You need to login to have access to uploads.

Also, I've tried with 2.90, instead of 2.91. Same thing

Hey Rafael,

I moved this to the correct forum (you postet it in the Pandora forum).

If the menu is empty there is an error when loading Prism. You should see that error in the terminal which you used to launch Blender.

I assume the PySide2 module included in Prism is not compatible with the version of Python on your system. If that's the case you can try to install PySide2 on your system and delete the one included in Prism.

Cheers,

Richard

Oh Hey Richard!

Sorry for the mess!

So, I've tried to reinstall and update Prism (1.3.0.69), and now I'm having this problem trying to install the Blender plugin. I already tried to run PrismSettings.sh with Sudo and no success. Houdini is working fine tho

Uploaded files:
  • You need to login to have access to uploads.

I've copied manually everything the installer complained to the Blender scripts directory and now it's working =)

Uploaded files:
  • You need to login to have access to uploads.

Great that you already found a workaround. I fixed that error in v1.3.0.70.

Hello!
I'm having a similar issue with no menu in blender 2.91 on linux.

Could you explain how to manually install the blender integration?
Is it the contents of /Prism/Plugins/Apps/Blender/Scripts  that I put into blenders install folder?  That is here in my case: usr/local/share/blender/2.91/

edit: I have tried running the Linux_Setup_Integrations.sh again and also tried to manually copy files.
Copying to /home/myuser/.config/blender/2.91 and adding that folder to Prism Integrations made the empty menu show up. Then I tried usr/local/share/blender/2.91/ which is the install directory. It threw the error shown in the attached image.

I have 2 versions of blender installed... 2.83 and 2.91, but neither have a working prism menu.

Thank you!

Uploaded files:
  • You need to login to have access to uploads.

Alright! Got it working.
My blender 2.91 install was running python 3.8 for some weird reason.

Downloaded a fresh blender, release candidat 2.92.

Installed PySide2 by running this in terminal: pip3 install PySide2

Copied these two folders PySide2, shiboken2
from /home/myuser/.local/lib/python3.8/site-packages/
to /home/myuser/Software/blender-2.92.0rc-linux64/2.92/python/lib/python3.7/site-packages

Ran the Prism_Setup_Linux.sh and pointed it to the 2.92 install dir /home/myuser/Software/blender-2.92.0rc-linux64/2.92/

All works now!
Thanks for the help Rafael!