Please or Register to create posts and topics.

Prism FTrack integration problem

Hi! Today we started setting up Prism 2 to optimize our pipeline. I had prior experience with Prism 1, been using it at another company for the last 3 years. The basic setup at this company worked really well, but we're having problems getting the ftrack connection to work.

We followed the documentation to get it to run. The first steps worked, we logged in to ftrack inside of Prism.

From the Prism documentation:

"After Prism logged in successfully in the setup dialog, you will see a list of your existing FTrack projects. Select the one you want to connect to Prism and click next."

^ This worked. We saw our ftrack projects in there.

From the Prism documentation:

On the next page you can select to which Prism project you want to connect it to. In most cases this will be your current Prism project, which is the first one in the list, which is already selected.

^ This didn't work. Upon clicking "next" on the desired ftrack project, a few small Prism windows quickly pop up and instantly disappear, bringing us back to Prism's project setting. We didnt have a chance to select a Prism Project to link to the selected ftrack project. We thought it just used the currently active project, but we aren't able to see any assets or shots inside of prism. We also already tried creating a new shot in ftrack after linking, but still nothing appears inside of prism.

May this be a bug or did we miss something? I would really appreciate some help here.

Kind regards,


Hello @otc-nick,

there was a small change in the setup, which hasn't been updated in the docs yet. There is no page anymore to select a Prism project, instead your currently active Prism project will be used. You should see a page at the end, which says that the projects are now connected.

Do you see the ftrack project name in the Prism Project Settings in the Project Management category? Do you see an ftrack menu in the Project Browser from where you can open your ftrack project in the Browser?

Are you using custom ftrack entities for assets and shots in ftrack? Prism is looking for entities of the default ftrack "Asset Build" and "Shot" types.

Do you have a TD in your team who is familiar with the ftrack Python API?


Hey Richard,

thanks for your reply. Last week I had a cold so I'm only able to answer now.

I can see the ftrack project in the project settings and also the ftrack menu in the project browser.

For assets on current projects we used something different than the default "Asset Build" type, but for shots we are using the default "Shot" type in ftrack. But the shots won't show up in Prism.

Sadly we don't really have a TD, we are quite a small team ^^

Also I just realised that I don't get a new page saying the projects are connected after connecting the projects, the dialogue simply closes and returns to Prism's projectsettings.


It's a tiny bit embarassing, but I figured out what the problem was. The shots on ftrack need to be inside of a sequence or a folder to appear in Prism, which our shots weren't. Now that I've put them into a sequence Prism can actually read them. Assets work aswell, when we use the proper Asset Build type.

Sorry for making a fuss about it, I really didn't know PrismĀ needs the shots to be inside of a sequence. Although it totally makes sense regarding Prism's internal structure. Maybe this is something that could be added to the documentation?

Kind regards,


Yes very good point, that will be added to the docs.